PC le6 Solid Lights

Questions about your PC3/PC3K/PC3LE/SP4/SP5 keyboard? Somebody might have the answers here.

PC le6 Solid Lights

Postby hydro2 » Fri Jan 12, 2018 2:32 pm

I have owned a PC le6 for about the past four years. About a year ago the light all the selection light buttons came on and stayed on. Some of them go off from time to time. I have read about the notorious button lights blinking randomly problem during my searches, but nobody seems to have the problem I have. It does not effect the play of the keyboard however, it does make it difficult to make to make adjustments because you can't tell what is selected and must refer to the LCD display when tweaking sounds. I have searched this forum, contacted Kurzweil directly and searched the net. I don't mind paying to have it repaired if the repair would a couple hundred or less. I use the board paired with a Nord Stage 2 EX and I am happy with the combo. Any insight or experience with this problem would be greatly appreciated. Kurzweil suggested that I re-set the board which I have. I also have the latest operating system on the board.
hydro2
Basement roach
Basement roach
 
Posts: 3
Joined: Tue Jan 09, 2018 8:06 am
Has thanked: 0 time
Have thanks: 1 time

Re: PC le6 Solid Lights

Postby happyrat1 » Sun Jan 14, 2018 4:35 pm

Have you tried opening it up and removing, cleaning and reseating the internal connectors?

Kurzweil is notorious for using crappy low cost connectors that tend to fail with time.

Gary ;)
User avatar
happyrat1
House of Blues alligator
House of Blues alligator
 
Posts: 122
Joined: Sun Jun 30, 2013 12:00 pm
Location: Ontario, Canada
Has thanked: 25 times
Have thanks: 26 times

Re: PC le6 Solid Lights

Postby hydro2 » Mon Jan 15, 2018 8:43 am

Thanks so much. I will give that a try when I get home tonight! Your response if greatly appreciated.

Mark
hydro2
Basement roach
Basement roach
 
Posts: 3
Joined: Tue Jan 09, 2018 8:06 am
Has thanked: 0 time
Have thanks: 1 time

Re: PC le6 Solid Lights

Postby Eclipse69 » Tue Jan 16, 2018 4:49 am

happyrat1 wrote:Have you tried opening it up and removing, cleaning and reseating the internal connectors?

Kurzweil is notorious for using crappy low cost connectors that tend to fail with time.

Gary ;)

True, very true :lol: ..... but I'm not sure that just cleaning the connectors will help.
Try first, through Kurzweil's support http://kurzweil.com/support/operational/ - it is unlikely to get, but try Jean Robert Bellefeuille is very polite and kind.
If this is not the case, I will contact you with a great technician from the authorized Kurzweil representative for the Czech Republic.
Good luck !!!
Eclipse69
Pub parrot
Pub parrot
 
Posts: 20
Joined: Wed Aug 23, 2017 5:00 am
Location: BULGARIA
Has thanked: 12 times
Have thanks: 0 time


Return to Kurzweil Discussion

Who is online

Users browsing this forum: No registered users and 2 guests


cron