Forum

Spread the love
Using pedal switche...
 
Notifications
Clear all

Using pedal switches to turn on and off zones.  

  RSS
Hooch
(@hooch)
Bring me to life Lister

I've been mapping pedals for all kinds of goodies and run in
to a snag.

I'm using switch pedal 3 and want to turn on zone 2 when held down
and have it go off when released.

What works is set it to cc7 with on value =127 and off value =0.
But I have to press it once to enable it.
After that it works correctly until I switch to
another program or multi.
Then I have to do that initial press again.

What am I doing wrong?

Never mind. Figured it out.
Entry and exit state need to be off.

I guess there may be a way to to do this with mutes
but how do you start with a muted zone
and turn it on and off with a single foot switch.

I figured out how to mute a zone that's on.

Thanks in advance. I'm learning as fast as I can.

John

Quote
Posted : 22/10/2015 1:16 am
jpuhakka
(@jpuhakka)
Bring me to life Lister

Hi John,

Try this:

SetupMode:FOOT SWITCH 3
Type: Toggle
OnControl: MuteZn
OnValue:127
OffControl: MuteZn
OffValue: 0

EntryState: On
ExitState: Off

Hope this works.

br,
jukka

PC3K8

ReplyQuote
Posted : 22/10/2015 7:04 am
Hooch
(@hooch)
Bring me to life Lister

If I'm reading that correctly its muting a zone
upon instantiation of the midi setup that gets
transmitted when you load something.

So the zone isn't stored muted.
The midi controller aspect mutes it correct?

I'm still puzzled that there isn't a dedicated
toggle to switch a zone on. Except the button on the front panel.

John

ReplyQuote
Posted : 23/10/2015 2:10 am
jpuhakka
(@jpuhakka)
Bring me to life Lister

I probably dont understand what you are asking. I understood that you want
1. zone to be muted every time you switch to that setup from other setup or program
2. zone to be unmuted when you push foot switch 3
3. zone to be muted again when you push foot switch 3 again
and so on.

br,
jukka

PC3K8

ReplyQuote
Posted : 23/10/2015 4:09 am
Hooch
(@hooch)
Bring me to life Lister

Yes. That is it exactly.
I'm going to try again tonight and use your suggestions.
I believe that I want the zone saved as unmuted and when the setup loads it will automatically mute it?

Thanks,

John

ReplyQuote
Posted : 25/10/2015 4:39 pm
Hooch
(@hooch)
Bring me to life Lister

Jukka,
Awesome. That worked.

So the zone mute function is doing its switch at the onset of the setup and mutes the zone.
Pressing the switches sets the function to 0 thereby undoing the mute.

I used momentary as the type and it worked too.
Holding the switch down gets me the stab sounding on that zone.
Let go of the switch and the stab is gone.
And no voices burned because your not using volume.

In the Forte right now there is only one destination type per control.
It still works because it is the same type.

Thank you so much.

John

ReplyQuote
Posted : 25/10/2015 5:12 pm
Ivan.ps
(@ivan-ps)
Viva la vida Lister

Can this somehow also set Kurzweil Artis please? I have an editor only those possibilities .

Mode: Toggled
Destination: Param149
ON Value: 127
OFF Value: 0
Entry State: NONE
Exit State: NONE

The zone is such command turned off , but then not again pedal turn . Please das and somehow solve ? thank you

ReplyQuote
Posted : 26/10/2015 8:04 am
Hooch
(@hooch)
Bring me to life Lister

I ran into a snag on this.
It only works if I boot up first, then plug in the pedal.

If I boot with pedals in?
The zone is not playing initially which is correct.
When you press the pedal nothing happens.
When you release the pedal the zone plays,
then the only way to get it to stop playing is hold it down.

What I want is a silent zone that only works while the switch pedal is pressed.
Releasing the pedal makes the zone silent.

Is this doable and I'm just not getting it?
Yes, another expression pedal would work but I'm out of room for 2 right now.

Thanks for any help.

John

ReplyQuote
Posted : 07/11/2015 1:16 am
jpuhakka
(@jpuhakka)
Bring me to life Lister

Hi John,

My first suggestion were wrong. Sorry about that.
These are the correct parameters (works with kurz pedal):

SetupMode:FOOT SWITCH 3
Type: Momentary
OnControl: MuteZn
OnValue:0
OffControl: MuteZn
OffValue: 127

EntryState: Off
ExitState: On

br,
jukka

PC3K8

ReplyQuote
Posted : 08/11/2015 3:11 am
cecchino
(@cecchino)
Never gonna give you up Lister Patron

Hi John,

My first suggestion were wrong. Sorry about that.
These are the correct parameters (works with kurz pedal):

SetupMode:FOOT SWITCH 3
Type: Momentary
OnControl: MuteZn
OnValue:0
OffControl: MuteZn
OffValue: 127

EntryState: Off
ExitState: On

br,
jukka

Hi John!
First of all, never boot the Kurz with pedal(s) disconneted. The auto-learning procedure (the one who finds if your pedal is normally open or normally closed, aka "polarity") will not work.
A zone should preferably be in "muted" state by default (on a PC3 this is set up on the main zone screen) if you want it muted when you select your setup. This may be accomplished as well by setting the Entry state of your pedal to Off as jukka wrote, while the Exit state only impacts on the subsequent selected setup (I would leave it Off).
If the pedal is in "Momentary" state, it will unmute the zone only while kept pressed. If you want this, jukka's setup is correct.
"Toggle" is instead the correct setup to unmute / mute again the zone with a single hit on the pedal (that means you hit the pedal and release it immediately when you need to change state). I use this because my right foot is dedicated to the sustain pedal and I use left foot to activate / deactivate leslie on KB3 programs, use the expression pedal etc. and I cannot leave it on the FS3 pedal ;)

HTH
C.

ReplyQuote
Posted : 08/11/2015 3:51 am
Hooch
(@hooch)
Bring me to life Lister

Cecchino,

Agreed about plugging in before powering on.
I normally do.

I found it didn't work if I did the correct thing because that's what I did on the next set up.
I must have thought of trying this after a rehearsal session started and plugged a pedal in with it on.

Jukka,
Thank you. That was it.
My previous understanding of it was close and backwards.

It doesn't matter whether the zone is on or off when you save it by the way.
The mute zone toggle is sent on entry of the multi.
Pressing the switch sends 0 which removes the mute.
Sweet!!

Thank you jukka's and all who chimed in. I'm learning.

Ivan,
I have the Forte and it looks just like the Artis.
My settings are

Controller:Sw Pedal 3
Mode: MIDI CC
Type: Momentary. You can use toggle here if you want it to latch on and off. I tried it. It works.
Destination: Mute Zone (149)
OnValue: 0
OffValue: 127
Entry State: Off
Exit State: On

Hope that helps
John

ReplyQuote
Posted : 12/11/2015 11:54 pm
Share: